TLSv1.2 Guidelines

  1. I. Troubleshooting for compatibility
    1. 1. Testing Browser compatibility for TLSv1.2
    2. 2. Testing Browser version
    3. 3. Testing Operating System version
  2. II. Compatibility guidelines for TLSv1.2
    1. 1. Operating System Compatibility
    2. 2. Browser Compatibility
  3. III. Upgrading for Compatibility
    1. 1. Steps to enable TLSv1.2 on the Browser
    2. 2. Upgrading Browser Version
    3. 3. Upgrading Operating System Version

I. Troubleshooting for compatibility

1. Testing Browser compatibility for TLSv1.2

The customer can test his/her browser compatibility for TLSv1.2, by visiting the below URL:
https://quickstream.westpac.com.au/quickportal/BrowserTlsVersionView

Browser is compatible

If the browser supports TLSv1.2 the customer will see the following.

Browser is incompatible

If the browser does not support TLSv1.2 the customer will receive the following page which has TLS 1.0 and TLS 1.1 disabled.

2. Testing Browser version

The customer can test his/her browser version by visiting the following URL:
https://www.whatismybrowser.com/

3. Testing Operating System version

The customer can test his/her OS version by visiting the following URL:
http://whatsmyos.com/

II. Compatibility guidelines for TLSv1.2

1. Operating System Compatibility

Operating System Version Customer Guidelines
Mac - Mac OS X 10.9 and below Your operating system does not support TLSv1.2 and must be upgraded to Mac OS X 10.9 or above
If operating system upgrade is not possible then the device must be changed.
Windows - Windows 3.1
- Windows XP
- Windows 95
- Windows NT
- Windows Vista
Your operating system does not support TLSv1.2 and must be upgraded to Windows 7 or above
If operating system upgrade is not possible then the device must be changed.
iOS - below iOS 7 Your operating system does not support TLSv1.2 and must be upgraded.
If operating system upgrade is not possible then the device must be changed.
Android - Android 4.4 and below Your operating system does not support TLSv1.2 and must be upgraded to 5 or above.
If operating system upgrade is not possible then the device must be changed.

2. Browser Compatibility

Google Chrome

Chrome Version Operating System Customer Guidelines
v1 through 29 - Windows 7 and up
- Mac OS X 10.9 and up
- Linux
- Android
- iOS 9 and up
- Chrome OS
Your web browser does not support TLSv1.2 and must be updated.
v30 through 58 - Windows 7 and up
- Mac OS X 10.9 and up
- Linux
- Android
- iOS 9 and up
- Chrome OS
Your web browser is supported.

Google Android OS Browser

Google Android OS Version Operating System Customer Guidelines
v1 through v4.0.4 Android Your web browser does not support TLSv1.2 and must be updated.
v4.1 through v4.4.4 Android You must enable support for TLSv1.2 in your browser.
v5 through v8 Android Your browser supports TLSv1.2

Mozilla Firefox

Mozilla Firefox Version Operating Systems Customer Guidelines
v1 through v23 - Windows 7 and up
- Mac OS X 10.9 and up
- Linux
- Android 4.0.3 and up
- iOS 9.0 and up
Your web browser does not support TLSv1.2 and must be updated.
v24 through v26 - Windows 7 and up
- Mac OS X 10.9 and up
- Linux
- Android 4.0.3 and up
- iOS 9.0 and up
You must enable support for TLSv1.2 in your browser.
v27 through v54 - Windows 7 and up
- Mac OS X 10.9 and up
- Linux
- Android 4.0.3 and up
- iOS 9.0 and up
Your browser supports TLSv1.2.

Mozilla Firefox ESR

Mozilla Firefox ESR Version Operating Systems Customer Guidelines
v10 through v17.0.10 - Windows XP SP2 and up
- Mac OS X 10.9 and up
- Linux
Your web browser does not support TLSv1.2 and must be updated.
v24 through v24.1.1 - Windows XP SP2 and up
- Mac OS X 10.9 and up
- Linux
You must enable support for TLSv1.2 in your browser.
v31 through v52.1 - Windows XP SP2 and up
- Mac OS X 10.9 and up
- Linux
Your browser supports TLSv1.2.

Microsoft Internet Explorer

Internet Explorer Version Operating System Customer Guidelines
IE8 Windows XP Your web browser does not support TLSv1.2 and must be updated.
IE8 Windows Server 2003 Your web browser does not support TLSv1.2 and must be updated.
IE8 Windows Vista Your web browser does not support TLSv1.2 and must be updated.
IE8 Windows 7 You must enable support for TLSv1.2 in your browser
IE8 Windows Server 2008 Your web browser does not support TLSv1.2 and must be updated.
IE8 Windows Server 2008 R2 You must enable support for TLSv1.2 in your browser.
IE8 Windows Server 2008 R2 You must enable support for TLSv1.2 in your browser.
IE9 Windows Vista Your web browser does not support TLSv1.2 and must be updated.
IE9 Windows 7 You must enable support for TLSv1.2 in your browser.
IE9 Windows Server 2008 Your web browser does not support TLSv1.2 and must be updated.
IE9 Windows Server 2008 R2 You must enable support for TLSv1.2 in your browser.
IE10 Windows 7 You must enable support for TLSv1.2 in your browser.
IE10 Windows 8 You must enable support for TLSv1.2 in your browser.
IE10 Windows Server 2008 R2 You must enable support for TLSv1.2 in your browser.
IE10 Windows Server 2012 You must enable support for TLSv1.2 in your browser.
IE11 Windows 7 Your browser supports TLSv1.2
IE11 Windows Server 2008 R2 Your browser supports TLSv1.2.
IE11 Windows 8.1 Your browser supports TLSv1.2.
IE11 Windows Server 2012 R2 Your browser supports TLSv1.2.

Microsoft Internet Explorer Mobile

Internet Explorer Mobile Version Operating System Customer Guidelines
v7 - Windows Phone 7
- Window Phone 7.5
- Window Phone 7.8
Your web browser does not support TLSv1.2 and must be updated.
v9 - Windows Phone 7
- Window Phone 7.5
- Window Phone 7.8
Your web browser does not support TLSv1.2 and must be updated.
v10 Windows Phone 8 You must enable support for TLSv1.2 in your browser.
v11 Windows Phone 8.1 Your browser supports TLSv1.2.

Microsoft Edge

Microsoft Edge Version Operating System Customer Guidelines
v12 Windows 10 v1507 Your browser supports TLSv1.2.
v13 Windows 10 v1511 Your browser supports TLSv1.2.
v14 Windows 10 v1607 Your browser supports TLSv1.2.
v15 Windows 10 v1703 Your browser supports TLSv1.2.
v16 Windows 10 v1709 Your browser supports TLSv1.2.

Opera

Opera Version Operating Systems Customer Guidelines
v1 through v9 - Windows 7 and up
- Mac OS X 10.9 and up
- Linux
- Android 4.0 and up
Your web browser does not support TLSv1.2 and must be updated.
v10 through v12.17 - Windows 7 and up
- Mac OS X 10.9 and up
- Linux
- Android 4.0 and up
You must enable support for TLSv1.2 in your browser.
v12.18 - Windows 7 and up
- Mac OS X 10.9 and up
- Linux
- Android 4.0 and up
Your browser supports TLSv1.2.
v14 through v16 - Windows 7 and up
- Mac OS X 10.9 and up
- Linux
- Android 4.0 and up
Your web browser does not support TLSv1.2 and must be updated.
v17 through v45 - Windows 7 and up
- Mac OS X 10.9 and up
- Linux
- Android 4.0 and up
Your browser supports TLSv1.2.

Apple Safari

Safari Version Operating Systems Customer Guidelines
v1 - Mac OS X 10.2 and up Your web browser does not support TLSv1.2 and must be updated.
v2 through v5 - Mac OS X 10.4, 10.5, 10.6, 10.7
- Windows XP
Your web browser does not support TLSv1.2 and must be updated.
v6 - MAC OS X 10.8 Your web browser does not support TLSv1.2 and must be updated.
v7 through v10 - Mac OS X 10.9, 10.10, 10.11, 10.12, 10.13
- iOS 1.0 and up
Your browser supports TLSv1.2.
v3 through v5 (iOS 3 and 4) - Mac OS X 10.2 and up
- iOS 1.0 and up
Your web browser does not support TLSv1.2 and must be updated.
v3 through v5 (iOS 3 and 4) - Mac OS X 10.2 and up
- iOS 1.0 and up
Your web browser does not support TLSv1.2 and must be updated.

Apple Safari Mobile

Safari Mobile Version Operating Systems Customer Guidelines
v3 iOS 1
iOS 2
Your web browser does not support TLSv1.2 and must be updated.
v4 through v5 iOS 3
iOS 4
Your web browser does not support TLSv1.2 and must be updated.
v5 through v6 iOS 5
iOS 6
Your browser supports TLSv1.2.
v7 iOS 7 Your browser supports TLSv1.2
v8 iOS 8 Your browser supports TLSv1.2
v9 iOS 9 Your browser supports TLSv1.2
v10 iOS 10 Your browser supports TLSv1.2
v11 iOS 11 Your browser supports TLSv1.2

III. Upgrading for Compatibility

1. Steps to enable TLSv1.2 on the Browser

The following lists steps to resolve TLSv1.2 compatibility for the most common internet browsers.

Microsoft Internet Explorer:

Steps to enable TLSv1.2 in Microsoft Internet Explorer

  1. Open Internet Explorer and click Tools > Internet Options.
  2. Check the boxes next to TLS 1.1 and TLSv1.2 to enable support for these protocols.
  3. Select the Advanced tab.
  4. Scroll down to the Security section at the bottom of the settings list.
  5. Check the boxes next to TLS 1.1 and TLSv1.2 to enable support for these protocols.
  6. Uncheck the box next to SSL 3.0 to disable this setting.
  7. Click Apply and OK.
  8. Close your browser and restart Internet Explorer.

Your browser is now ready to support the TLSv1.2 protocol.

Mozilla Firefox:

Steps to enable TLSv1.2 in Mozilla Firefox

  1. Open Firefox
  2. In the URL/address bar, type about:config and press Enter.
  3. In the Search field, enter tls. Locate and double-click the entry for security.tls.version.min
  4. Set the Integer Value to 3 to enable support for TLSv1.2.
  5. Click OK
  6. Close your browser and restart Mozilla Firefox.

Your browser is now ready to support the TLSv1.2 protocol.

Google Chrome:

Steps to enable TLSv1.2 in Google Chrome

  1. From the browser click the Customize tab on right most corner and click settings.
  2. Scroll down to Network and click change proxy settings
  3. In the Internet Properties, click advanced tab and scroll down to Security. Tick TLSv1.2checkbox.

Your browser is now ready to support the TLSv1.2 protocol.

Opera

  1. Open Opera.
  2. Click Ctrl plus F12.
  3. Scroll down to the Network section and click Change proxy settings...
  4. Select the Advanced tab.
  5. Scroll down to the Security section and check check the boxes next to Use TLS 1.1 and Use TLSv1.2.
  6. Click Ok.
  7. Close your browser and restart Opera.

Your browser is now ready to support the TLSv1.2 protocol.

Apple Safari:

There are no options for enabling SSL protocols. If the customer is using Safari version 7 or greater, TLS 1.1 and TLSv1.2 are automatically enabled.

2. Upgrading Browser Version

The customer can visit the relevant links mentioned below, in order to upgrade to the latest browser version.

Google Chrome
https://www.google.com/chrome/

Google Android OS Browser
https://play.google.com/store/apps/details?id=org.easyweb.browser&hl=en

Mozilla Firefox
https://www.mozilla.org/en-US/firefox/enterprise/

Mozilla Firefox ESR
https://www.mozilla.org/en-US/firefox/organizations/

Microsoft Internet Explorer
https://www.microsoft.com/en-us/download/internet-explorer.aspx

Microsoft Internet Explorer Mobile
https://support.microsoft.com/en-us/hub/4338813/windows-help?os=windows-16

Opera
https://www.opera.com/o/ie-simple

Apple Safari
https://support.apple.com/downloads/safari

Apple Safari Mobile
https://support.apple.com/downloads/safari

3. Upgrading Operating System Version

The customer needs to contact the Customer Services for further help.